Issues making and receiving calls

Incident Report for NUACOM

Resolved

The issue has been resolved. Apologies for the inconvenience caused.
Posted Feb 19, 2026 - 10:31 GMT

Monitoring

The rollback has been implemented at 10:04 GMT, and we are monitoring the systems.
Posted Feb 19, 2026 - 10:16 GMT

Identified

We have identified an issue with a recent update that is affecting our database, slowing it down.
We are rolling back the changes and will come with an update soon.
Posted Feb 19, 2026 - 09:56 GMT
This incident affected: Desktop App, Mobile App, Cloud PBX, Incoming Calls, and Outbound Calls.