Investigating issues with Management Portal ,Severity: major

Incident Report for NUACOM

Resolved

This incident has been resolved.
Posted Jun 14, 2024 - 17:53 IST

Investigating

We are investigating an incident affecting Management Portal. We will provide updates via email and Statuspage shortly.
Posted Jun 14, 2024 - 17:45 IST