Mobile app degraded performance, you may have issue to make and receive calls

Incident Report for NUACOM

Resolved

The issue has now been resolved.
To apply the changes, please log out of the mobile app and log back in.
Posted Apr 07, 2026 - 14:22 IST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 07, 2026 - 14:16 IST

Investigating

We are investigating the issue
Posted Apr 07, 2026 - 13:49 IST
This incident affected: Mobile App, Incoming Calls, and Outbound Calls.