Public API server error

Incident Report for NUACOM

Postmortem

Service Incident Summary – January 23, 2026

On January 23, 2026, Nuacom experienced a service disruption that affected access to the platform for a period of time.

What happened

Between 02:30 and 07:41 (Ireland time), some customers experienced difficulties accessing Nuacom services. This included issues with the web portal, apps, and API-dependent features. A small number of customers also experienced temporary visibility issues with SMS history.

Impact

  • Some users were unable to access services during the incident window
  • Core SMS delivery continued to function as normal
  • The issue was resolved the same morning and all services were restored

Resolution

Our engineering team identified the cause of the disruption and applied corrective actions to restore full service. The system has been stable since resolution, and we continue to monitor performance closely.

Data and records

No customer configuration data was lost. In cases where call or message history was temporarily unavailable during the incident, visibility has now been restored where applicable.

Preventive actions

We have reviewed our deployment and monitoring processes and are implementing improvements to:

  • Detect similar issues earlier
  • Reduce the likelihood of recurrence
  • Improve communication during incidents

Our apology

We apologise for the inconvenience caused and appreciate your patience and understanding. If you have any questions or notice anything unusual, please contact our support team.

Posted Jan 26, 2026 - 11:29 GMT

Resolved

API 500 Server Error
Posted Jan 23, 2026 - 02:00 GMT