Issue with incoming calls

Incident Report for NUACOM

Resolved

This incident has been resolved.
Posted May 06, 2026 - 13:55 IST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 06, 2026 - 11:03 IST

Identified

We have identified the cause of the issue affecting incoming calls.
Our engineers are currently monitoring the situation closely.
We appreciate your patience and will continue to provide updates.
Posted May 06, 2026 - 10:53 IST

Investigating

We are currently experiencing an issue affecting incoming calls. Some customers may find that inbound calls are not being received.
Our team is actively investigating the cause. Further updates will be posted here shortly.
Posted May 06, 2026 - 10:45 IST
This incident affected: Incoming Calls.