IOS app degraded performance, you may have issue to receive incoming calls

Incident Report for NUACOM

Resolved

The incident is now resoved, sorry for the inconvenience caused,
the team is continuing the investigation into the root cause.
Posted Oct 23, 2025 - 16:42 IST

Investigating

We are currently investigating this issue.
Posted Oct 23, 2025 - 15:36 IST
This incident affected: Mobile App and Incoming Calls.